• Auteur: Root
  • Datum: 6-05-2020

De techniek, en daarmee ook het internet, is continu in ontwikkeling. Voor veilig internet is het daarom van groot belang dat protocollen up-to-date zijn. De makers van de meest gebruikte browsers Internet Explorer, Edge, Firefox en Chrome hebben dan ook aangekondigd de verouderde TLS-protocollen versie 1.0 en 1.1 uit te gaan faseren. Dit betekent dat vanaf dat moment alleen de nieuwe versies, TLS 1.2 en 1.3, geaccepteerd zullen worden.

Wat is TLS?

TLS, ofwel “Transport Layer Security”, is een protocol dat zorgt voor de bescherming van het netwerk middels een SSL (“Secure Sockets Layer”) certificaat. Elke website waar het webadres begint met https:// heeft zo’n SSL-certificaat en gebruikt een versie van TLS om het verkeer tussen de browser en de website te versleutelen. Het TLS-protocol zorgt er hiermee voor dat gegevens die uitgewisseld worden tussen een browser en server beveiligd zijn.

TLS 1.0 bestaat al 20 jaar en was de opvolger van SSLv3 welke al jaren geleden uit gefaseerd is. Vanwege beveiligingsrisico’s is nu dus besloten om ook TLS 1.0 en zijn opvolger uit 2006, TLS 1.1 uit te faseren.

Server upgrade

Wanneer browsers de ondersteuning van de verouderde TLS-protocollen beëindigen, is het van belang dat server- en website eigenaren aan hun kant het gebruik van TLS 1.0 en 1.1 uitschakelen. Clientcomputers en browsers die geen TLS 1.2 ondersteunen zijn inmiddels minstens 5 jaar oud. Dit betekent dat gebruikers deze eigenlijk allang hadden moeten vervangen of updaten. Bij Root hebben we al sinds vorig jaar standaard alle nieuwe uitgerolde servers enkel van TLS 1.2 ondersteuning voorzien en sinds kort is het zelfs mogelijk om het nog nieuwere TLS 1.3 te ondersteunen!

Waarom een server upgrade?

Wanneer browsers de ondersteuning voor het gebruik van oude TLS-protocollen beëindigen, waarom is het dan van belang dat dit ook aan de serverkant moet gebeuren? Eenvoudig gesteld: de oude TLS-versies worden niet voor niets uit gefaseerd. Deze zijn simpelweg niet meer veilig. Zolang servers en websites toch deze oude TLS-protocollen toestaan, kunnen sterk verouderde computers nog steeds blijven verbinden op een manier die niet langer veilig is. Kwaadwillende personen kunnen dit verkeer nog steeds onderscheppen en zo proberen data te lezen die niet voor hun bestemd is.

Het uit faseren van TLS 1.0 en 1.1 is op de meeste webservers een kleine moeite. Root helpt u graag uw servers en website veilig te houden. Wilt u meer informatie? Neem gerust contact met ons op!

Neem contact op met
een van onze specialisten