IP Scope: 2001:DB8:1234::/48
WAN IP: 2001:DB8:1234::2/64
Gateway: 2001:DB8:1234::1/64
LAN: 2001:DB8:1234:ABCD::/64 

Enable IPv6:
/system package
enable ipv6

Reboot om package te installeren
/system reboot

Voeg ipv6 addressen toe aan interfaces en enable SLAAC op LAN:
/ipv6 address
add address=2001:DB8:1234::2/64 interface=ether1
add address=2001:DB8:1234:ABCD::1/64 interface=bridge advertise=yes

Voeg default route toe voor IPv6:
/ipv6 route
add distance=1 gateway=2001:DB8:1234::1/64

Maak een DHCPv6 pool
/ipv6 pool
add name=DHCPv6_Pool prefix=2001:DB8:1234:ABCD:100::/72 prefix-length=124

Maak DHCPv6 opties:
/ipv6 dhcp-server option
add code=23 name=Root_DNS value=0x2a0213980000000800000000000000672a021398000000080000000000000068
(Hier gebruiken we 2a02:1398::67 & 2a02:1398::68)

Maak de DHCPv6 server:
/ipv6 dhcp-server
add address-pool=DHCPv6_Pool dhcp-option=Root_DNS interface=bridge lease-time=1d name=server1

Zorg voor Neighbor discovery:
/ipv6 nd
add interface=bridge managed-address-configuration=yes other-configuration=yes

Maak een aantal IPv6 address-list's voor gebruik in firewallregels:
/ipv6 firewall address-list

add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
add address=::224.0.0.0/100 comment="defconf: other" list=bad_ipv6
add address=::127.0.0.0/104 comment="defconf: other" list=bad_ipv6
add address=::/104 comment="defconf: other" list=bad_ipv6
add address=::255.0.0.0/104 comment="defconf: other" list=bad_ipv6

Maak diverse input en forward regels om verkeer mogelijk te maken vanuit het LAN en blokkeer diverse bogon networks:

/ipv6 firewall filter

add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" disabled=yes port=33434-33534 protocol=udp
add action=drop chain=input comment="defconf: drop everything else not coming from LAN" in-interface-list=!bridge
add action=accept chain=forward comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=icmpv6
add action=drop chain=forward comment="defconf: drop everything else not coming from LAN" in-interface-list=!bridge

Als namens uw domeinnaam e-mail verzonden wordt vanaf de Root mailservers kan de volgende include worden opgenomen in het DNS SPF-record:

include:_spf.root.nl

Bijvoorbeeld: v=spf1 a include:_spf.root.nl -all


Als namens uw domeinnaam e-mail verzonden wordt vanaf de Root Shared Webhosting (DirectAdmin) kan de volgende include worden opgenomen in het DNS SPF-record:

include:_spf-da.root.nl

Bijvoorbeeld: v=spf1 a include:_spf-da.root.nl -all

Als u e-mail als dienst afneemt bij Root kunt u de volgende mailserver-instellingen gebruiken:

Server voor inkomende e-mail: mail.echelon.nl
Server voor uitgaande e-mail (SMTP): mail.echelon.nl
Inkomende e-mail (IMAP): poort 993 (TLS)
Uitgaande e-mail (SMTP): poort 25 (TLS)  [alternatief: poort 2525 (TLS)  (*)]

(*) Bij gebruik van poort 2525 is authenticatie noodzakelijk wanneer de Root mailservers de e-mail moeten relayen (verder doorsturen naar externe mailservers).

Als u een internetaansluiting heeft van Root kunt u de volgende DNS-servers gebruiken:

  • 217.119.226.67
  • 217.119.226.68